四平方和定理,又称为拉格朗日定理:
每个正整数都可以表示为至多 4 个正整数的平方和。
如果把 0 包括进去,就正好可以表示为 4 个数的平方和。
比如:
5=0^2+0^2+1^2+2^2
7=1^2+1^2+1^2+2^2
对于一个给定的正整数,可能存在多种平方和的表示法。
要求你对 4 个数排序:
0≤a≤b≤c≤d
并对所有的可能表示法按 a,b,c,d 为联合主键升序排列,最后输出第一个表示法。
输入格式
输入一个正整数 N。
输出格式
输出4个非负整数,按从小到大排序,中间用空格分开。
数据范围
0<N<5∗106
输入样例:
5
输出样例:
0 0 1 2
暴力:能过掉大部分的数据
但结果超时
#include <cstdio> using namespace std; const int N = 1e7; int nn ; int main(){
scanf("%d",&nn); for(int i = 0;i<2500;i++){ for(int j = i;j<2500;j++){ for(int
m =j;m<2500;m++){ for(int n = m;n<2500;n++){ if(i*i+j*j+m*m+n*n==nn){
printf("%d %d %d %d",i,j,m,n); return 0; } } } } } return 0; }
优化:
减掉一层for循环 又过了两个测试点 结果仍然超时
#include <cstdio> #include <cmath> using namespace std; const double N = 1e7;
double nn ; int main(){ scanf("%lf",&nn); for(double i = 0;i<2500;i++){
for(double j = i;j<2500;j++){ for(double m =j;m<2500;m++){
if(sqrt(nn-i*i-j*j-m*m)==(int)sqrt(nn-i*i-j*j-m*m)){ printf("%d %d %d
%d",(int)i,(int)j,(int)m,(int)sqrt(nn-i*i-j*j-m*m)); return 0; } } } } return
0; }
优化判断过程:
#include <cstdio> #include <cmath> using namespace std; const int N = 1e7; int
nn ; int main(){ scanf("%d",&nn); for(int i = 0;i*i<nn;i++){ for(int j =
i;i*i+j*j<nn;j++){ for(int m =j;i*i+j*j+m*m<nn;m++){ int t = nn-i*i-j*j-m*m;
int k = sqrt(t); if(k*k==t){ printf("%d %d %d %d",i,j,m,k); return 0; } } } } }